Logo of the Java RMI Plug-in for Eclipse

RMI Plug-in for Eclipse
version 2.0

Developing Java RMI applications finally made easy!


News

12/Sep/2010

Version 2.1.6 released, supports Eclipse 3.5.x

06/Jun/2008

Please report issues with RMI Plug-in & Eclipse 3.4. Thanks!

5/Oct/2007

Version 2.0.7 offers enhanced support for Eclipse 3.3 (Europa).

1/June/2007

Summer special - order a site license and get an RMI book!

21/Mar/2007

Version 2.0.6 released with fixes and improved Vista support.

23/Nov/2006

Flash demos and tutorials added (more to come!)

11/Nov/2006

JBuilder 2007 is now officially supported.

Eclipse.org
JBuilder 2007

About

The RMI Plug-in for Eclipse is the most comprehensive solution for developing Java RMI systems using the Eclipse platform. Besides generation of the stub and skeleton files using the "rmic" compiler, the RMI Plug-in will help you getting started with the Java RMI technology and will provide advanced configuration, analysis and debugging tools.

Feature List:

A word on the Java RMI technology

RMI is a java framework of communication between two Java processes on a class/method invocation level. This allows to create more complex systems than one could create with plain sockets. RMI in Java is similar to Remoting in .NET. To learn more about Java RMI check the Java RMI Resources page.

Free or commercial? Is there a trial version?

The RMI Plug-in for Eclipse is a low-priced commercial software and an even lower priced academic licenses are available as well. Check it yourself - view the price list and place an order (upgrades from v1.6 are also available). The files that are available for download contain a trial version that is fully functional for 15 days after installation (no license key is required for the evaluation). If a longer evaluation period is required, please fill this form.

In addition to commercial and academic offerings free personal licenses are also available for personal and open source projects. Check the personal licenses page for the terms of the personal licensing program.

Eclipse version support

RMI Plugin for Eclipse v2.0 requires Eclipse 3.1.2 and 3.2 and will work with products based on
these versions. RMI Plug-in for Eclipse v2.0 also supports RAD/RSA 6.0, but a number of small features are not available. Future releases of Eclipse based tools by IBM and other companies will be supported a short time after they are released. Previous versions of the RMI Plug-in provide support for some older versions of WSAD.

Java version supported: All recent Java versions are supported (from JDK 1.4.2 to Java 6.0 beta). Usually the RMI Plug-in will use the internal "rmic" interface, but sometimes it may have to revert to executing the command line version of "rmic". Previous Java versions (1.1, 1.2, 1.3) are not officially supported.

Previous versions

Previous versions of the RMI Plug-in for Eclipse are still available for customers that require compatibility with earlier Eclipse / RAD / RSA / WSAD releases:

>>> Download Now <<<

RMI Plugin for Eclipse v2.0 supports Eclipse 3.1.2 and 3.2 as well as other products based on
these versions (e.g., Callisto). By downloading the RMI Plugin for Eclipse you accept the License Agreement.


© 2002-14 Genady Beryozkin, rmi-info@genady.net. Read our Privacy policy. Hosted on RimuHosting. Visit Javalobby.